
<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8"><script type="text/javascript">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</script>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>

	<meta name='robots' content='max-image-preview:large' />
<script>window._wca = window._wca || [];</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Florida Title CEO spurred to action after Texas winter storms - HousingWire</title>
	<meta name="description" content="A Florida native found himself in the thick of the Texas winter storms, which eventually led to national coverage of his selfless deeds." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Florida Title CEO spurred to action after Texas winter storms - HousingWire" />
	<meta property="og:description" content="A Florida native found himself in the thick of the Texas winter storms, which eventually led to national coverage of his selfless deeds." />
	<meta property="og:url" content="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/" />
	<meta property="og:site_name" content="HousingWire" />
	<meta property="article:publisher" content="https://www.facebook.com/HousingWire/" />
	<meta property="article:published_time" content="2021-05-27T22:22:39+00:00" />
	<meta property="article:modified_time" content="2021-05-27T22:22:42+00:00" />
	<meta property="og:image" content="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="713" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@housingwire" />
	<meta name="twitter:site" content="@housingwire" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Tim Glaze">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.housingwire.com/#organization","name":"HousingWire","url":"https://www.housingwire.com/","sameAs":["https://www.facebook.com/HousingWire/","https://www.linkedin.com/company/housingwire","https://twitter.com/housingwire"],"logo":{"@type":"ImageObject","@id":"https://www.housingwire.com/#logo","inLanguage":"en-US","url":"https://www.housingwire.com/wp-content/uploads/2020/01/HW_Bug.jpg","width":823,"height":823,"caption":"HousingWire"},"image":{"@id":"https://www.housingwire.com/#logo"}},{"@type":"WebSite","@id":"https://www.housingwire.com/#website","url":"https://www.housingwire.com/","name":"HousingWire","description":"HousingWire is the nation&#039;s most influential source of news and information on housing and mortgage lending.","publisher":{"@id":"https://www.housingwire.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.housingwire.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#primaryimage","inLanguage":"en-US","url":"https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png","width":1200,"height":713,"caption":"hands holding a picture of a house"},{"@type":"WebPage","@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#webpage","url":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/","name":"Florida Title CEO spurred to action after Texas winter storms - HousingWire","isPartOf":{"@id":"https://www.housingwire.com/#website"},"primaryImageOfPage":{"@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#primaryimage"},"datePublished":"2021-05-27T22:22:39+00:00","dateModified":"2021-05-27T22:22:42+00:00","description":"A Florida native found himself in the thick of the Texas winter storms, which eventually led to national coverage of his selfless deeds.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/"]}]},{"@type":"NewsArticle","@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#article","isPartOf":{"@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#webpage"},"author":{"@id":"https://www.housingwire.com/#/schema/person/a595c2c853220e4b7d9653768ecf4aea"},"headline":"Florida Title CEO spurred to action after Texas winter storms","datePublished":"2021-05-27T22:22:39+00:00","dateModified":"2021-05-27T22:22:42+00:00","mainEntityOfPage":{"@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.housingwire.com/#organization"},"image":{"@id":"https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#primaryimage"},"keywords":"aaron davis,AMD Enterprises,HWplus","articleSection":"Kudos","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/#respond"]}],"copyrightYear":"2021","copyrightHolder":{"@id":"https://www.housingwire.com/#organization"}},{"@type":"Person","@id":"https://www.housingwire.com/#/schema/person/a595c2c853220e4b7d9653768ecf4aea","name":"Tim Glaze","image":{"@type":"ImageObject","@id":"https://www.housingwire.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c4500d94e5b92b201a567429864fe7fb?s=96&d=mm&r=g","caption":"Tim Glaze"},"description":"Tim Glaze is an assignment reporter for HousingWire. He graduated from the University of North Texas in 2009 and immediately began working in print and digital media. He's published bylines in the Dallas Morning News, D Magazine, People Newspapers and Star Local Media. A lifelong Dallasite, Tim currently lives in Sanger with his wife, Danielle."}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="HousingWire &raquo; Feed" href="https://www.housingwire.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="HousingWire &raquo; Comments Feed" href="https://www.housingwire.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="HousingWire &raquo; Florida Title CEO spurred to action after Texas winter storms Comments Feed" href="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.housingwire.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<!-- WP Fusion --><style type="text/css">.woocommerce .product .variations option:disabled { display: none; } </style><link rel='stylesheet' id='all-css-0' href='https://www.housingwire.com/_static/??-eJytj0EOgzAMBD/UYKVF7anqW8CxwCKxUZwU8XugnCr12OtqZ6SBZXYsGGsgAzSDwFagj4qTi9znLq9gZY3UJJZmP1xgJ1ClkBSYYx1YDBZV1JQoI8Hc4dQN9DW6j9CgrxwDvEmCZnOn9z/O364yUtqpUauxDAtnOvuOUApcNB/IKz39/eof3t/adgMKDmcK' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='how-editor-fonts-css'  href='https://fonts.googleapis.com/css2?family=Poppins%3Awght%40300%3B400%3B500%3B600%3B700&#038;display=swap&#038;ver=5.7.2' media='all' />
<style id='woocommerce-inline-inline-css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='all-css-4' href='https://www.housingwire.com/_static/??-eJyVj9EKwjAMRX/ILkyH4oP4KVLbuFWbpjQtw793GwrKJuhbcrnnkEAfleGQMWSIvrQuCAxR1EnQ39/GyoisYKnNbJgIk0FFSGdM0rkooEUwCwwYXNLEWOjNe0W98opcmPlzh4QCHRdxoe1dQrBO8iQk/ScwJh5nCBX1euOKOWpzU/tqB8S2+EElnU5otbX3aRwcvxpOLhgQNk575bll+VgW//1iGq9/7iNypEO9Xde7ut40zQMEL6YG' type='text/css' media='all' />
<script type='text/javascript' src='https://www.housingwire.com/_static/??-eJyFyzEOgCAMheELKQ1qdDKexUijJVKUlhBvL4O70xv+70G52i2yIivogQEFjpiFeC+UEByJghdARxqT8dJAPRBvZ3aV1uLvjOn5xgTiX9QG2tOq+OElzHbs7GRtPwz+BXcGNMg='></script>
<script defer src='https://stats.wp.com/s-202121.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://www.housingwire.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.housingwire.com/wp-json/wp/v2/posts/307078" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.housingwire.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.housingwire.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<meta name="generator" content="WooCommerce 5.0.0" />
<link rel='shortlink' href='https://www.housingwire.com/?p=307078' />
<link rel="alternate" type="application/json+oembed" href="https://www.housingwire.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.housingwire.com%2Farticles%2Fflorida-title-ceo-spurred-to-action-after-texas-winter-storms%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.housingwire.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.housingwire.com%2Farticles%2Fflorida-title-ceo-spurred-to-action-after-texas-winter-storms%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 2.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="2.0"/>
			<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.housingwire.com\/articles\/florida-title-ceo-spurred-to-action-after-texas-winter-storms\/"},"headline":"Florida Title CEO spurred to action after Texas winter storms","url":"http:\/\/www.housingwire.com\/articles\/florida-title-ceo-spurred-to-action-after-texas-winter-storms\/","thumbnailUrl":"https:\/\/www.housingwire.com\/wp-content\/uploads\/2020\/09\/house-and-hands-HW.png?w=150","image":{"@type":"ImageObject","url":"https:\/\/www.housingwire.com\/wp-content\/uploads\/2020\/09\/house-and-hands-HW.png?w=150"},"dateCreated":"2021-05-27T22:22:39Z","datePublished":"2021-05-27T22:22:39Z","dateModified":"2021-05-27T22:22:39Z","articleSection":"Kudos","author":[{"@type":"Person","name":"Tim Glaze"}],"creator":["Tim Glaze"],"keywords":["aaron davis","amd enterprises","hwplus"],"publisher":{"@type":"Organization","name":"HousingWire","logo":{"@type":"ImageObject","url":"https:\/\/www.housingwire.com\/wp-content\/uploads\/2019\/09\/HW-logo1.png"}}}
		</script>

			<!-- END wp-parsely Plugin Version 2.0 -->
<style type='text/css'>img#wpstats{display:none}</style>
			<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<script>(window.gaDevIds=window.gaDevIds||[]).push('5CDcaG');</script>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<!-- There is no amphtml version available for this URL. --><link rel="icon" href="https://www.housingwire.com/wp-content/uploads/2019/09/cropped-HW-logo1-e1615477616160.png?w=32" sizes="32x32" />
<link rel="icon" href="https://www.housingwire.com/wp-content/uploads/2019/09/cropped-HW-logo1-e1615477616160.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.housingwire.com/wp-content/uploads/2019/09/cropped-HW-logo1-e1615477616160.png?w=180" />
<meta name="msapplication-TileImage" content="https://www.housingwire.com/wp-content/uploads/2019/09/cropped-HW-logo1-e1615477616160.png?w=270" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-8355216-9']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->

	<script>
		window.dataLayer = window.dataLayer || [];
		window.dataLayer.push({
			'event': 'userData',
			'loggedin': "false",
			'userID': "0",
			'membership': "false",
			'registered': "false"		});

					window.dataLayer.push({
				'event': 'viewedContent',
				'author': 'Tim Glaze',
			});
				</script>

	<!-- Google Tag Manager -->
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-PVVGVBC');</script>
	<!-- End Google Tag Manager -->

	<!-- Global site tag (gtag.js) - Google Analytics - No Pageview -->
	<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1056573-1"></script>

	
	<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments);}
		gtag('js', new Date());

		gtag('config', 'UA-1056573-1', { 'send_page_view': false });
	</script>

	<!-- Google Ad -->
			<script>
			window.googletag = window.googletag || {cmd: []};
			googletag.cmd.push( function() {
														var pushdownMapping = googletag.sizeMapping().addSize([1024, 0], [[970, 250], [970, 90]]).addSize([740, 0], [728, 90]).addSize([0, 0], [320, 50]).build();
					googletag.defineSlot('/21614384512/housingwire/pushdown', [[970, 250], [970, 90], [320, 50], [728, 90]], 'pushdown' ).defineSizeMapping(pushdownMapping).addService(googletag.pubads());

					
					
					
											var medrectAMapping = googletag.sizeMapping().addSize([1024, 0], [[300, 600], [300, 250]]).addSize([740, 0], [[300, 600], [300, 250]]).addSize([0, 0], []).build();
						googletag.defineSlot('/21614384512/housingwire/medrect_a', [[300, 250], [300, 600]], 'medrect_a' ).defineSizeMapping(medrectAMapping).addService(googletag.pubads());
						
											var medrectBMapping = googletag.sizeMapping().addSize([1024, 0], [[300, 600], [300, 250]]).addSize([740, 0], [[300, 600], [300, 250]]).addSize([0, 0], []).build();
						googletag.defineSlot('/21614384512/housingwire/medrect_b', [[300, 250], [300, 600]], 'medrect_b' ).defineSizeMapping(medrectBMapping).addService(googletag.pubads());
					
				//      *** Defining key-value targeting for the test page ***
				
			googletag.pubads().enableLazyLoad({
				fetchMarginPercent: 100,  // Fetch slots within 1 viewports.
				renderMarginPercent: 100,  // Render slots within 1 viewports.
			});

			googletag.pubads().setTargeting('page_type', ["articles"]);
			googletag.pubads().setTargeting('taxonomy', []);
			googletag.pubads().setTargeting('articletopic', ['Kudos']);
			googletag.pubads().setTargeting('keyword', []);
			googletag.pubads().setTargeting('tags', ['aaron davis', 'AMD Enterprises', 'HWplus']);

			googletag.pubads().enableSingleRequest();
			googletag.pubads().collapseEmptyDivs();

			googletag.enableServices();
			});
		</script>
		<!-- END of Google Ad -->

	</head>


<body class="post-template post-template-templates post-template-full-width-article post-template-templatesfull-width-article-php single single-post postid-307078 single-format-standard wp-custom-logo theme-housingwire woocommerce-no-js has-blocks woocommerce-active">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PVVGVBC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header">
		<!-------------- Top Nav Grid Container -------------->
		<div class="grid-container">
			<div class="grid-x align-middle">

				<!-- logo -->
				<div class="cell shrink">
					<div class="site-branding">
													<p><a href="https://www.housingwire.com/" class="custom-logo-link" rel="home"><img width="375" height="375" src="https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png" class="custom-logo jetpack-lazy-image" alt="HW-logo" data-attachment-id="205737" data-permalink="https://www.housingwire.com/hw-logo/" data-orig-file="https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png" data-orig-size="375,375" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="HW-logo" data-image-description="" data-medium-file="https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png?w=300" data-large-file="https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png?w=375" data-lazy-srcset="https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png 375w, https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png?resize=150,150 150w, https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png?resize=300,300 300w, https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png?resize=100,100 100w" data-lazy-sizes="(max-width: 375px) 100vw, 375px" data-lazy-src="https://www.housingwire.com/wp-content/uploads/2019/09/HW-logo1.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></p>
												</div><!-- .site-branding -->
				</div>

				<!-- rest of header -->
				<div class="cell auto">
					<nav id="site-navigation" class="main-navigation bottom-border">

						<!------ top menu bar ------>
						<div class="grid-x align-justify align-middle">
							<!-- powered-by -->
							
							<!-- social menu -->
							<nav class="cell medium-shrink social">
								<ul class="no-bullet flex-container align-center">
									<li class="social__facebook"><a href="https://www.facebook.com/HousingWire/" target="_blank"><i class="fab fa-facebook-f" aria-hidden="true"></i><span class="screen-reader-text">Facebook</span></a></li>
									<li class="social__instagram"><a href="https://www.instagram.com/housingwire" target="_blank"><i class="fab fa-instagram" aria-hidden="true"></i><span class="screen-reader-text">Instagram</span></a></li>
									<li class="social__twitter"><a href="https://twitter.com/housingwire" target="_blank"><i class="fab fa-twitter" aria-hidden="true"></i><span class="screen-reader-text">Twitter</span></a></li>
									<li class="social__linkedin"><a href="https://www.linkedin.com/company/housingwire" target="_blank"><i class="fab fa-linkedin-in" aria-hidden="true"></i><span class="screen-reader-text">LinkedIn</span></a></li>
								</ul>
							</nav>

							<!-- extras menu -->
							<nav class="cell medium-auto flex-container align-right extras">
								<ul class="no-bullet flex-container align-middle">
									<li class="extras__newsletter"><a href="https://www.housingwire.com/newsletter">Newsletters</a></li>
																			<li class="extras__join"><a href="https://www.housingwire.com/membership"><span>Join</span> HW+</a></li>
																					<li><button class="extras__login" data-open="loginModal">Log In</button></li>
																				<li class="extras__search">
												<form action="https://www.housingwire.com/">
			<input type="text" name="s" placeholder="Search Site" class="hide">
			<button class="button__search" type="button">
				<span class="extras__search--open">
					<i class="fa fa-search" aria-hidden="true" title="open search bar"></i>
					<span class="screen-reader-text">open search bar</span>
				</span>
				<span class="extras__search--close hide">
					<i class="far fa-times" aria-hidden="true" title="close search bar"></i>
					<span class="screen-reader-text">close search bar</span>
				</span>
			</button>
		</form>
										</li>
									<li class="extras__hamburger">
										<button><i class="fa fa-bars fa-lg" aria-hidden="true" title="toggle menu"></i></button>
										<span class="screen-reader-text">open menu</span>
									</li>
								</ul>
							</nav>

							<!------ overlay & main menu ------>
							<div class="cell small-12 overlay">
								<form action="https://www.housingwire.com/" class="overlay__search hide">
									<input type="text" name="s" placeholder="Search Here">
									<button type="submit" class="button__search">
										<i class="fa fa-search" aria-hidden="true" title="search site"></i>
										<span class="screen-reader-text">search site</span>
									</button>
								</form>
								<div class="main-menu">
									<nav class="menu-main-menu-container"><ul id="main-menu-top" class="menu"><li id="menu-item-206314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-206314"><a href="https://www.housingwire.com/category/mortgage/">Mortgage</a>
<ul class="sub-menu">
	<li id="menu-item-206315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206315"><a href="https://www.housingwire.com/category/mortgage/origination/">Origination</a></li>
	<li id="menu-item-289918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-289918"><a href="https://www.housingwire.com/category/ma-funding/">IPO / M&amp;A</a></li>
	<li id="menu-item-206317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206317"><a href="https://www.housingwire.com/category/mortgage/servicing/">Servicing</a></li>
	<li id="menu-item-206318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206318"><a href="https://www.housingwire.com/category/mortgage/secondary/">Secondary</a></li>
	<li id="menu-item-258101" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258101"><a href="https://www.housingwire.com/mortgage-rates-center/">Mortgage Rates Center</a></li>
	<li id="menu-item-206336" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206336"><a href="https://www.housingwire.com/category/politics-money/cfpb-regulatory/">Regulatory</a></li>
</ul>
</li>
<li id="menu-item-206322" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-206322"><a href="https://www.housingwire.com/category/real-estate/">Real Estate</a>
<ul class="sub-menu">
	<li id="menu-item-206324" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206324"><a href="https://www.housingwire.com/category/real-estate/housing-market/">Housing Market</a></li>
	<li id="menu-item-206323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206323"><a href="https://www.housingwire.com/category/real-estate/agents-brokers/">Agents/Brokers</a></li>
	<li id="menu-item-296141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296141"><a href="https://www.housingwire.com/category/appraisals-valuations/">Appraisals &amp; Valuations</a></li>
	<li id="menu-item-288656" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-288656"><a href="https://www.housingwire.com/category/politics-money/economics/">Economics</a></li>
	<li id="menu-item-234758" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-234758"><a href="https://www.housingwire.com/category/real-estate/affordable-housing/">Affordable Housing</a></li>
	<li id="menu-item-281676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-281676"><a href="https://www.housingwire.com/category/real-estate-enthusiasts/">Enthusiasts</a></li>
</ul>
</li>
<li id="menu-item-272024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-272024"><a href="https://www.housingwire.com/category/title-escrow/">Closing</a></li>
<li id="menu-item-233251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-233251"><a href="https://www.housingwire.com/hwplus/">HW+</a>
<ul class="sub-menu">
	<li id="menu-item-262644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-262644"><a href="https://www.housingwire.com/housingstack/">HousingStack</a></li>
	<li id="menu-item-252438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252438"><a href="https://www.housingwire.com/category/magazine-issues/">Magazine Issues</a></li>
	<li id="menu-item-297003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297003"><a href="https://www.housingwire.com/articles/housingwire-spring-summit-2021/">HousingWire Spring Summit on demand</a></li>
	<li id="menu-item-301551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-301551"><a href="https://www.housingwire.com/membership/">HW+ Membership</a></li>
</ul>
</li>
<li id="menu-item-205784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-205784"><a>Knowledge</a>
<ul class="sub-menu">
	<li id="menu-item-205786" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205786"><a href="https://www.housingwire.com/white-paper/">White Papers</a></li>
	<li id="menu-item-205787" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205787"><a href="https://www.housingwire.com/webinar/">Webinars</a></li>
	<li id="menu-item-205794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205794"><a href="https://www.housingwire.com/videos/">Videos</a></li>
	<li id="menu-item-205788" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205788"><a href="https://www.housingwire.com/directories/">Services Guide</a></li>
</ul>
</li>
<li id="menu-item-205793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-205793"><a href="https://www.housingwire.com/engage/">Events</a>
<ul class="sub-menu">
	<li id="menu-item-292052" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-292052"><a href="https://www.housingwire.com/engage/event/engage-marketing/">engage.marketing</a></li>
	<li id="menu-item-291913" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-291913"><a href="https://www.housingwire.com/engage/event/hw-annual-2021/">HousingWire Annual</a></li>
	<li id="menu-item-242714" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-242714"><a href="https://www.housingwire.com/engage/event/mortgage-tech-virtual-demo-day/">Virtual Demo Day</a></li>
	<li id="menu-item-205799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205799"><a href="https://www.housingwire.com/engage/event/hw-spring-summit-2021/">HousingWire Spring Summit</a></li>
</ul>
</li>
<li id="menu-item-205795" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-205795"><a href="https://www.housingwire.com/podcast/">Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-288280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-288280"><a href="https://www.housingwire.com/shows/housingwire-daily/">HousingWire Daily</a></li>
	<li id="menu-item-288281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-288281"><a href="https://www.housingwire.com/shows/housing-news-season-6/">Housing News</a></li>
	<li id="menu-item-302867" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-302867"><a href="https://www.housingwire.com/shows/honest-conversations/">Honest Conversations</a></li>
	<li id="menu-item-288279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-288279"><a href="https://www.housingwire.com/shows/girlfunds/">Girlfunds</a></li>
</ul>
</li>
<li id="menu-item-288283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-288283"><a href="https://www.housingwire.com/editors-choice-awards/">Awards</a>
<ul class="sub-menu">
	<li id="menu-item-304705" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-304705"><a href="https://www.housingwire.com/articles/here-are-the-2021-hw-finance-leaders/">2021 HW Finance Leaders</a></li>
	<li id="menu-item-295327" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-295327"><a href="https://www.housingwire.com/articles/introducing-the-2021-hw-tech100-mortgage-winners/">2021 HW Tech100 Mortgage Winners</a></li>
	<li id="menu-item-295326" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-295326"><a href="https://www.housingwire.com/articles/introducing-the-2021-hw-tech100-real-estate-winners/">2021 HW Tech100 Real Estate Winners</a></li>
	<li id="menu-item-295328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295328"><a href="https://www.housingwire.com/editors-choice-awards/">Nominate for Awards</a></li>
</ul>
</li>
</ul></nav>								</div>
								<button class="overlay__newsletter hide"><a href="https://www.housingwire.com/newsletter">Newsletters</a></button>
																	<button class="overlay__login hide" data-open="loginModal">Log In</button>
																</div>
						</div><!-- /.grid-x -->
					</nav><!-- #site-navigation -->
				</div>

			</div><!-- /.grid-x -->
		</div><!-- /.grid-container -->
	</header><!-- #masthead -->


							<div class="grid-container grid-x grid-padding-y grid-padding-x top-bar-posts slick-slider" data-slick='{"slidesToShow": 1, "arrows": false, "infinite": true, "mobileFirst": true, "responsive": [{ "breakpoint": 768, "settings": "unslick" } ]}'>
							<div class="cell medium-3 align-middle grid-x single">
						<div class="cell small-3 align-middle image">
															<div class="container__img">
																			<a href="https://www.housingwire.com/webinar/why-traditional-loan-sales-are-holding-you-back/" target="_blank">
											<img src="https://www.housingwire.com/wp-content/uploads/2020/03/AdobeStock_217569562-e1586208829672.jpeg?resize=120,120" alt="Technology for navigating secondary market challenges">
										</a>
																		</div>
													</div>
						<div class="cell small-9 content">
																<a href="https://www.housingwire.com/webinar/why-traditional-loan-sales-are-holding-you-back/" target="_blank">
										Technology for navigating secondary market challenges									</a>
																		<p>Join this webinar to learn how mortgage lenders can overcome common challenges selling their loans on the secondary market.</p>
														</div>
					</div>
										<div class="cell medium-3 align-middle grid-x single">
						<div class="cell small-3 align-middle image">
															<div class="container__img">
																			<a href="https://www.housingwire.com/podcast/logan-mohtashami-talks-jobs-report-mortgage-forbearance/" target="_blank">
											<img src="https://www.housingwire.com/wp-content/uploads/2020/11/Screen-Shot-2020-11-11-at-4.07.52-PM.png?resize=120,120" alt="Logan Mohtashami talks jobs report, mortgage forbearance">
										</a>
																		</div>
													</div>
						<div class="cell small-9 content">
																<a href="https://www.housingwire.com/podcast/logan-mohtashami-talks-jobs-report-mortgage-forbearance/" target="_blank">
										Logan Mohtashami talks jobs report, mortgage forbearance									</a>
																		<p>Lead Analyst Logan Mohtashami discusses his recent article on the latest jobs report and the most likely impact on the housing market and mortgage forbearance.</p>
														</div>
					</div>
										<div class="cell medium-3 align-middle grid-x single">
						<div class="cell small-3 align-middle image">
															<div class="container__img">
																			<a href="https://www.housingwire.com/articles/real-estate-agents-hold-breath-on-commission-disclosure-ruling/" target="_blank">
											<img src="https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-commission.jpg?resize=120,120" alt="Real estate agents hold breath on commission disclosure">
										</a>
																		</div>
													</div>
						<div class="cell small-9 content">
																<a href="https://www.housingwire.com/articles/real-estate-agents-hold-breath-on-commission-disclosure-ruling/" target="_blank">
										Real estate agents hold breath on commission disclosure									</a>
																		<p>Whether real estate agents must tell homebuyers what commission percentage they stand to make is now in the hands of the Justice Department. </p>
														</div>
					</div>
										<div class="cell medium-3 align-middle grid-x single">
						<div class="cell small-3 align-middle image">
															<div class="container__img">
																			<a href="https://www.housingwire.com/articles/how-lenders-can-prepare-for-growing-fraud-threats/" target="_blank">
											<img src="https://www.housingwire.com/wp-content/uploads/2020/12/technology2.jpeg?resize=120,120" alt="How lenders can prepare for growing fraud threats">
										</a>
																		</div>
													</div>
						<div class="cell small-9 content">
																<a href="https://www.housingwire.com/articles/how-lenders-can-prepare-for-growing-fraud-threats/" target="_blank">
										How lenders can prepare for growing fraud threats									</a>
																		<p>HousingWire recently spoke with Jeffrey Morelli, general manager at Truework, about what lenders can do to prepare for and overcome the growing threat of fraud and data inaccuracy.</p>
														</div>
					</div>
							</div>
		
	<div id="content" class="site-content">

		<div class="grid-container">
							<!----- Top Banner ad ----->
				<div class="grid-x grid-margin-x">
					<div class="cell">
							<div class="advertisement advertisement__top-leaderboard" id="pushdown">
		<script>
			googletag.cmd.push(function() { googletag.display( "pushdown" ); });
		</script>
	</div>
						</div>
				</div><!-- /.grid-x -->
				
	<div id="primary" class="content-area article-full-width">
		<main id="main" class="site-main">
			<div class="grid-container width-900">
				<div class="grid-x grid-margin-x grid-margin-y">
					<div class="cell">

						
							
<div class="cell text-center post-307078 post type-post status-publish format-standard has-post-thumbnail hentry category-kudos tag-aaron-davis tag-amd-enterprises tag-hwplus" >
	<header class="entry-header width-900">

					<span class="cat-links">
				<a href="https://www.housingwire.com/category/opinion/" rel="category tag">Opinion</a>			</span>
							<div class="text-center exclusive-content-logo">
				<img src="https://www.housingwire.com/wp-content/themes/housingwire/img/hwplus-exclusive-contentlogo.png" width="300" title="HW+ Exclusive Content">
			</div>
				<h1 class="page-title">Florida Title CEO spurred to action after Texas winter storms</h1>		<p class="sub-title">Nicknamed the “Tampa Chainsaw Man,” Aaron Davis inspires an industry to give back</p>		<div class="social-by-line flex-container flex-dir-column align-middle">
			<div class="by-line">
									<span class="date">May 27, 2021, 6:22 pm</span>
					<span class="author">By <a href="https://www.housingwire.com/author/tglaze/" title="Posts by Tim Glaze" class="author url fn" rel="author">Tim Glaze</a></span>								</div>
			<div class="flex-container align-center-middle social">
				<span>Share On</span>
				<div class="flex-container">
					<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-307078" class="share-twitter sd-button share-icon no-text" href="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-307078" class="share-facebook sd-button share-icon no-text" href="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-307078" class="share-linkedin sd-button share-icon no-text" href="https://www.housingwire.com/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>				</div>
			</div>
		</div>
			</header><!-- .entry-header -->
</div>

							<div class="cell">
								<article id="post-307078">

	<div class="entry-content">
		
<div class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="271783" data-permalink="https://www.housingwire.com/articles/housings-v-shaped-recovery-is-complete-what-had-to-happen-to-get-america-back-by-sept-1/house-and-hands-hw/" data-orig-file="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png" data-orig-size="1200,713" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="house and hands HW+" data-image-description data-medium-file="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=300" data-large-file="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=1024" loading="lazy" width="1200" height="713" src="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=1024" alt="hands holding a picture of a house" class="wp-image-271783 jetpack-lazy-image" data-lazy-srcset="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png 1200w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=150,89 150w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=300,178 300w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=768,456 768w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=1024,608 1024w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=600,357 600w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=1024&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="271783" data-permalink="https://www.housingwire.com/articles/housings-v-shaped-recovery-is-complete-what-had-to-happen-to-get-america-back-by-sept-1/house-and-hands-hw/" data-orig-file="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png" data-orig-size="1200,713" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="house and hands HW+" data-image-description="" data-medium-file="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=300" data-large-file="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=1024" loading="lazy" width="1200" height="713" src="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?w=1024" alt="hands holding a picture of a house" class="wp-image-271783" srcset="https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png 1200w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=150,89 150w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=300,178 300w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=768,456 768w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=1024,608 1024w, https://www.housingwire.com/wp-content/uploads/2020/09/house-and-hands-HW.png?resize=600,357 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript></figure></div>



<p>After unprecedented winter storms ravaged large parts of <a href="https://www.texastribune.org/series/winter-storm-power-outage/" target="_blank" rel="noreferrer noopener">Texas in February</a>, Florida native Aaron Davis — always one to volunteer his time for those in need — found himself in the thick of the devastation in Harper, Texas, a decision that led eventually to national coverage of his selfless deeds.</p>



<p>“The weight of snow and ice on trees, roofs, and structures — it was incredibly similar to a hurricane, which I’m accustomed to preparing for on a regular basis, being from Florida,” he said. “This was the equivalent of a week-long hurricane, mixed with Arctic temperatures, and no power.” </p>



<p>Aptly nicknamed the “Tampa Chainsaw Man,” Davis, who is the CEO of <strong>AMD Enterprises</strong>, a conglomerate of title business ventures, including Florida Agency Network and Premier Data Services, was ready to help in the disaster relief efforts in Texas.</p>



<p>“What I witnessed in Harper the day after I arrived was amazing,” he said. “Truckloads of food and supplies arriving, people from neighboring towns showing up to help their neighbors, whether to offer a shower, help cut tree limbs, donate funds, and do whatever was needed to help.” </p>



<p>And how did Davis end up in Harper? He wanted to go somewhere he could be of use and even told his job he was “taking a month off” to volunteer in Texas. </p>



<p>Davis’ girlfriend lives in Austin, and he flew to the city following a pipe bursting in her home due to the winter storms. Once she was secure with friends and family helping, as Davis explained, he started looking for some additional opportunities in the area to volunteer. That’s when he was led to Lakeway Church, near Lake Travis in the Austin area. </p>


		<div class="wp-block-woocommerce-memberships-member-content">
					<div class="woocommerce">
			<div class="woocommerce-info wc-memberships-restriction-message wc-memberships-message wc-memberships-content-restricted-message">
				<h2>This content is exclusively for HW+ members.</h2>

Start an <u><span class="wc-memberships-products-grant-access"><a href="https://www.housingwire.com/product/hw-membership/">HW+ Membership</a></span></u> now for less than $1 per day. 
<p>
Your HW+ Membership includes: 
<p> 
<p style="text-left">
<li>Unlimited access to HW+ articles and analysis</li>
<li>Exclusive access to the HW+ Slack community and virtual events</li>
<li>HousingWire Magazine delivered to your home or office</li>
<p>
<p style="text-center">
<h2><a href="url">BECOME A MEMBER TODAY</a></h2>
<p>
<p>
Already a member? <u><a href="https://www.housingwire.com/my-account/?wcm_redirect_to=post&#038;wcm_redirect_id=307078">log in</a></u>		    </div>
		</div>
				</div>
		</p>	</div><!-- .entry-content -->

</article><!-- #post-307078 -->

								
										<!----- Article Posts ----->
		<div class="grid-x grid-margin-x grid-margin-y article-posts-cards">

			<!-- Most Popular -->
								<div class="cell large-6">
						<div class="grid-x">
							<div class="cell">
								<h2 class="has-red-line--no-after">Most Popular Articles</h2>
								
<div class="featured-post grey-background flex-container flex-dir-column post-306987 post type-post status-publish format-standard has-post-thumbnail hentry category-agents-brokers category-brokerage category-real-estate tag-hwplus tag-national-association-of-realtors tag-real-estate-commissions tag-u-s-department-of-justice tag-zillow" >
			<div class="container__img">
			<a href="https://www.housingwire.com/articles/real-estate-agents-hold-breath-on-commission-disclosure-ruling/">
				<img class=" jetpack-lazy-image" src="https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-commission.jpg?w=1024&#038;resize=540,275" alt="HW+ real estate agent commission" data-lazy-src="https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-commission.jpg?w=1024&amp;is-pending-load=1#038;resize=540,275" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="" src=" https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-commission.jpg?w=1024&#038;resize=540,275" alt="HW+ real estate agent commission" /></noscript>			</a>
		</div>
		<div class="container__txt flex-container flex-dir-column align-justify">
		<div class="container__txt--main">
		<a class="entry-title" href="https://www.housingwire.com/articles/real-estate-agents-hold-breath-on-commission-disclosure-ruling/" rel="bookmark">Real estate agents hold breath on commission disclosure</a>		<p>Whether real estate agents must tell homebuyers what commission percentage they stand to make is now in the hands of the Justice Department. HW+ Premium Content</p>
		</div>
		<div>
			<span class="date-posted">May 25, 2021</span>			<span class="author">By <a href="https://www.housingwire.com/author/mblake/" title="Posts by Matthew Blake" class="author url fn" rel="author">Matthew Blake</a></span>		</div>
	</div>
</div>
							</div>
							<div class="cell">
								<ul class="posts-list posts-list--articles no-bullet">
									
<li class="posts-list__item container__txt bottom-border post-307230 post type-post status-publish format-standard has-post-thumbnail hentry category-affordable-housing category-origination category-politics-money tag-al-lawson tag-bonnie-watson-coleman tag-fha tag-fha-loan tag-first-responders tag-homes-for-every-loacl-protector-educator-and-responder-act tag-john-katko tag-john-rutherford tag-legislation tag-teachers tag-veteran-affairs tag-veterans-administration" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/va-like-housing-bill-proposed-for-first-responders-teachers/" rel="bookmark">VA-like housing bill proposed for first responders, teachers</a></h3>	  <div>
  <span class="date-posted">May 25, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/georgia-kromrei/" title="Posts by Georgia Kromrei" class="author url fn" rel="author">Georgia Kromrei</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-306855 post type-post status-publish format-standard has-post-thumbnail hentry category-housing-market category-real-estate tag-daryl-fairweather tag-homebuying tag-housing-demand tag-housing-market-2021 tag-low-inventory tag-mortgage-rates tag-pending-sales tag-purchase-applications tag-redfin tag-sellers-market" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/housing-demand-weakening-redfin-may/" rel="bookmark">Is housing market demand starting to weaken?</a></h3>	  <div>
  <span class="date-posted">May 21, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/tglaze/" title="Posts by Tim Glaze" class="author url fn" rel="author">Tim Glaze</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-307099 post type-post status-publish format-standard has-post-thumbnail hentry category-mortgage category-servicing tag-fannie-mae-forbearance tag-forbearance tag-freddie-mac-forbearance tag-ginnie-mae-forbearance tag-mba tag-mike-fratantoni tag-mortgage-bankers-association tag-portfolio-and-private-loans tag-private-label-securities tag-what-is-forbearance" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/mortgage-forbearance-drops-third-month-mba/" rel="bookmark">Forbearance numbers drop for third consecutive month</a></h3>	  <div>
  <span class="date-posted">May 24, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/alexroha/" title="Posts by Alex Roha" class="author url fn" rel="author">Alex Roha</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-306952 post type-post status-publish format-standard has-post-thumbnail hentry category-economics category-housing-market tag-america-is-back-model tag-existing-home-sales tag-housing-demographics tag-housing-inventory tag-hwplus tag-mortgage-rates tag-national-association-of-realtors tag-purchase-applications" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/existing-home-sales-data-a-bad-sign-for-housing-market/" rel="bookmark">Existing home sales data: A bad sign for housing market?</a></h3>	  <div>
  <span class="date-posted">May 21, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/logan-mohtashami/" title="Posts by Logan Mohtashami" class="author url fn" rel="author">Logan Mohtashami</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-307435 post type-post status-publish format-standard has-post-thumbnail hentry category-mortgage category-origination tag-ellie-mae tag-featured tag-ice-mortgage-technology tag-joe-tyrrell tag-loan-types tag-mortgage-applications tag-origination-insight-report" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/lenders-pick-up-the-pace-in-closing-mortgages/" rel="bookmark">Lenders pick up the pace in closing mortgages</a></h3>	  <div>
  <span class="date-posted">May 26, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/tglaze/" title="Posts by Tim Glaze" class="author url fn" rel="author">Tim Glaze</a></span>    </div>
  
</li>
								</ul>
							</div>
						</div>
					</div>
					
			<!-- Latest -->
							<div class="cell large-6">
					<div class="grid-x">
						<div class="cell">
							<h2 class="has-red-line--no-after">Latest Articles</h2>
							
<div class="featured-post grey-background flex-container flex-dir-column post-307662 post type-post status-publish format-standard has-post-thumbnail hentry category-agents-brokers category-real-estate tag-hwplus tag-real-estate tag-real-estate-broker" >
			<div class="container__img">
			<a href="https://www.housingwire.com/articles/real-estate-agents-and-the-housing-market/">
				<img class=" jetpack-lazy-image" src="https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-showing-homes.jpg?w=1024&#038;resize=540,275" alt="HW+ real estate agent showing homes" data-lazy-src="https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-showing-homes.jpg?w=1024&amp;is-pending-load=1#038;resize=540,275" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="" src=" https://www.housingwire.com/wp-content/uploads/2021/05/HW-real-estate-agent-showing-homes.jpg?w=1024&#038;resize=540,275" alt="HW+ real estate agent showing homes" /></noscript>			</a>
		</div>
		<div class="container__txt flex-container flex-dir-column align-justify">
		<div class="container__txt--main">
		<a class="entry-title" href="https://www.housingwire.com/articles/real-estate-agents-and-the-housing-market/" rel="bookmark">How is the housing market impacting real estate agents?</a>		<p>There’s plenty of advice available to help buyers and sellers navigate the current market. But what about real estate agents? HW+ Premium Content</p>
		</div>
		<div>
			<span class="date-posted">May 27, 2021</span>			<span class="author">By <a href="https://www.housingwire.com/author/robyn-a-friedman/" title="Posts by Robyn A. Friedman" class="author url fn" rel="author">Robyn A. Friedman</a></span>		</div>
	</div>
</div>
						</div>
						<div class="cell">
							<ul class="posts-list posts-list--articles no-bullet">
								
<li class="posts-list__item container__txt bottom-border post-307642 post type-post status-publish format-standard has-post-thumbnail hentry category-brokerage category-real-estate tag-1031-exchange tag-agents-and-brokers tag-hwplus tag-idaho tag-infrastructure-bill tag-lumber tag-national-association-of-realtors" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/a-conversation-with-nars-newest-leader/" rel="bookmark">A conversation with NAR&#8217;s newest leader</a></h3>	  <div>
  <span class="date-posted">May 27, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/mblake/" title="Posts by Matthew Blake" class="author url fn" rel="author">Matthew Blake</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-307526 post type-post status-publish format-standard has-post-thumbnail hentry category-mortgage category-politics-money tag-alden-knowlton tag-capitol-hill tag-morpac tag-mortgage-bankers-association tag-rachel-kelley" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/mba-promotes-knowlton-adds-kelley-to-political-teams/" rel="bookmark">MBA promotes Knowlton, adds Kelley to political teams</a></h3>	  <div>
  <span class="date-posted">May 27, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/tglaze/" title="Posts by Tim Glaze" class="author url fn" rel="author">Tim Glaze</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-307560 post type-post status-publish format-standard has-post-thumbnail hentry category-housing-market category-real-estate tag-homes-for-sale tag-inventory-shortage tag-joel-kan tag-lawrence-yun tag-nar tag-nar-pending-home-sales tag-national-association-of-realtors tag-new-home-sales tag-pending-home-sales" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/low-inventory-stifles-aprils-pending-home-sales/" rel="bookmark">Low inventory stifles April&#8217;s pending home sales</a></h3>	  <div>
  <span class="date-posted">May 27, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/alexroha/" title="Posts by Alex Roha" class="author url fn" rel="author">Alex Roha</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-307515 post type-post status-publish format-standard has-post-thumbnail hentry category-title-escrow tag-adeptive-software tag-datatrace tag-eclosings tag-gorkem-kuterdem tag-softpro tag-title-and-closing tag-wfg-national-title-insurance-company" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/softpro-names-gorkem-kuterdem-cto/" rel="bookmark">SoftPro names Gorkem Kuterdem CTO</a></h3>	  <div>
  <span class="date-posted">May 27, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/tglaze/" title="Posts by Tim Glaze" class="author url fn" rel="author">Tim Glaze</a></span>    </div>
  
</li>

<li class="posts-list__item container__txt bottom-border post-307520 post type-post status-publish format-standard has-post-thumbnail hentry category-mortgage category-mortgage-rates tag-freddie-mac tag-freddie-mac-pmms tag-mortgage-rates tag-mortgage-rates-2021 tag-rising-rates tag-sam-khater tag-what-are-todays-mortgage-rates" >
	<h3><a class="entry-title" href="https://www.housingwire.com/articles/mortgage-rates-drop-below-3-again/" rel="bookmark">Mortgage rates drop below 3% again</a></h3>	  <div>
  <span class="date-posted">May 27, 2021</span><span class="author">By <a href="https://www.housingwire.com/author/alexroha/" title="Posts by Alex Roha" class="author url fn" rel="author">Alex Roha</a></span>    </div>
  
</li>
							</ul>
						</div>

					</div>
				</div>
						</div>
									</div>

							
					</div>
				</div>
			</div>
		</main><!-- #main -->
	</div><!-- #primary -->


			</div><!--/.grid-container -->
		</div><!-- #content -->

		
		<div class="ad-break"></div>
		<footer class="alignfull">
			<div class="grid-container">
								<nav class="grid-x grid-margin-x grid-padding-x align-justify">
					<section id="nav_menu-2" class="widget cell medium-3 widget_nav_menu"><h3 class="widget-title">HousingWire</h3><div class="menu-footer-housingwire-container"><ul id="menu-footer-housingwire" class="menu"><li id="menu-item-206360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206360"><a href="https://www.housingwire.com/category/mortgage/">Mortgage News</a></li>
<li id="menu-item-206361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206361"><a href="https://www.housingwire.com/category/real-estate/">Real Estate News</a></li>
<li id="menu-item-206362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-206362"><a href="https://www.housingwire.com/category/fintech/">FinTech News</a></li>
</ul></div></section><section id="nav_menu-3" class="widget cell medium-3 widget_nav_menu"><h3 class="widget-title">Community</h3><div class="menu-footer-hw-community-container"><ul id="menu-footer-hw-community" class="menu"><li id="menu-item-36718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36718"><a href="https://www.housingwire.com/engage">Engage Events</a></li>
<li id="menu-item-207709" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-207709"><a href="https://www.housingwire.com/editors-choice-awards/">Editors&#8217; Choice Awards</a></li>
<li id="menu-item-277014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277014"><a href="https://www.housingwire.com/category/real-estate-enthusiasts/">Real Estate Enthusiasts</a></li>
</ul></div></section><section id="nav_menu-4" class="widget cell medium-3 widget_nav_menu"><h3 class="widget-title">Advertise With HW</h3><div class="menu-footer-advertise-with-hw-container"><ul id="menu-footer-advertise-with-hw" class="menu"><li id="menu-item-36735" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36735"><a href="https://www.housingwire.com/advertise/#digital-advertising">Digital Advertising</a></li>
<li id="menu-item-36736" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36736"><a href="https://www.housingwire.com/advertise/#hw-content-solutions">HW Content Solutions</a></li>
<li id="menu-item-36737" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36737"><a href="https://www.housingwire.com/advertise/#print-advertising">Print Advertising</a></li>
<li id="menu-item-36738" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36738"><a href="https://www.housingwire.com/advertise/#contact-us">Download Rate Card</a></li>
</ul></div></section><section id="nav_menu-5" class="widget cell medium-3 widget_nav_menu"><h3 class="widget-title">Company</h3><div class="menu-footer-company-container"><ul id="menu-footer-company" class="menu"><li id="menu-item-216323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-216323"><a href="https://www.housingwire.com/category/hwmedia-hq/">HW Media HQ</a></li>
<li id="menu-item-255554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255554"><a href="https://www.housingwire.com/about/">About</a></li>
<li id="menu-item-205885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205885"><a href="https://www.housingwire.com/contact/">Contact Us</a></li>
<li id="menu-item-205893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205893"><a href="https://www.housingwire.com/licensing-permissions-and-reprints/">Licensing &#038; Reprints</a></li>
<li id="menu-item-211241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-211241"><a href="https://www.housingwire.com/jobs/">Jobs</a></li>
</ul></div></section>				</nav><!-- /.grid-x for Footer: Menu -->

								<div class="grid-x grid-margin-x social-legal align-middle">
					<div class="cell large-shrink">
						<ul class="no-bullet social social--round flex-container align-center">
							<li class="social__facebook"><a href="https://www.facebook.com/HousingWire/" target="_blank"><i class="fab fa-facebook-f" aria-hidden="true"></i><span class="screen-reader-text">Facebook</span></a></li>
							<li class="social__instagram"><a href="https://www.instagram.com/housingwire" target="_blank"><i class="fab fa-instagram" aria-hidden="true"></i><span class="screen-reader-text">Instagram</span></a></li>
							<li class="social__twitter"><a href="https://twitter.com/housingwire" target="_blank"><i class="fab fa-twitter" aria-hidden="true"></i><span class="screen-reader-text">Twitter</span></a></li>
							<li class="social__linkedin"><a href="https://www.linkedin.com/company/housingwire" target="_blank"><i class="fab fa-linkedin-in" aria-hidden="true"></i><span class="screen-reader-text">LinkedIn</span></a></li>
						</ul>
					</div>
					<div class="cell large-auto text-center">
						<span>© 2006-2021 HW Media, LLC. All rights reserved. Site by <a href="https://trewknowledge.com/" target="_blank">Trew Knowledge.</a><br />Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=www.housingwire.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
					</div>
					<div class="cell large-shrink">
						<div class="menu-footer-institutional-container"><ul id="menu-footer-institutional" class="menu"><li id="menu-item-36717" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-36717"><a href="https://www.housingwire.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>					</div>
				</div><!-- /.grid-x for Footer: Social & Legal -->

			</div><!-- /.grid-container -->
		</footer>
	</div><!-- #page -->

			<!-- login modal -->
		<div class="reveal login-modal" id="loginModal" data-reveal>
			<div class="grid-x">
				<div class="cell medium-6 container__img">
					<img src="https://www.housingwire.com/wp-content/themes/housingwire/img/login-house.png?resize=583,555" alt="3d rendering of a row of luxury townhouses along a street" data-lazy-src="https://www.housingwire.com/wp-content/themes/housingwire/img/login-house.png?resize=583%2C555&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src=" https://www.housingwire.com/wp-content/themes/housingwire/img/login-house.png?resize=583,555" alt="3d rendering of a row of luxury townhouses along a street" /></noscript>				</div>
				<div class="cell medium-6 container__txt flex-container align-middle">
					<button class="button__close" data-close aria-label="close modal" type="button">
						<i class="fa-2x fa-times fal" aria-hidden="true" title="close modal"></i>
					</button>

							<form id="login_form" class="form" action="login" method="post">
			<div class="grid-x grid-margin-x grid-margin-y">
				<div class="cell">
					<h2 class="text-center">Log In</h2>
				</div>
				<div class="cell text-center no-margin-bottom">
											<span class="btn-twitter"><a href="https://www.linkedin.com/oauth/v2/authorization?response_type=code&#038;client_id=78wtirlpecps78&#038;redirect_uri=https://www.housingwire.com/wp-login.php?vip_social_login_provider=linkedin&#038;scope=r_liteprofile%20r_emailaddress" class="vsl-provider linkedin" data-provider="linkedin">Log in with LinkedIn</a> OR </span>
										</div>
				<div class="cell no-top-margin">
					<div class="form-status-message"></div>
					<label for="user_login" class="screen-reader-text ">Email</label>
					<input placeholder="Email" name="user_login" id="user_login" class="required" type="text"/>
					<label for="user_pass" class="screen-reader-text ">Password</label>
					<input placeholder="Password" name="user_pass" id="user_pass" class="required" type="password"/>
					<p class="form-row">
						<label class="woocommerce-form__label woocommerce-form__label-for-checkbox woocommerce-form-login__rememberme">
							<input class="woocommerce-form__input woocommerce-form__input-checkbox" name="rememberme" type="checkbox" id="user_remember" value="forever" checked="checked">
							<span>Remember me</span>
						</label>
					</p>
					<a href="https://www.housingwire.com/my-account/lost-password/">Forgot Password?</a>
				</div>
				<div class="cell text-center">
					<input type="hidden" id="ajax_url" name="ajax_url" value="https://www.housingwire.com/wp-admin/admin-ajax.php">
					<input type="hidden" id="how_login_nonce" name="how_login_nonce" value="b097b9b6ef" /><input type="hidden" name="_wp_http_referer" value="/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/" />					<input id="login_submit" class="button medium" type="submit" value="Login"/>
					<p>Don't have an account? <span class="no-break">Please <a href="https://www.housingwire.com/membership" class="sign-up">Sign Up</a></span></p>
				</div>
			</div>
		</form>
		
				</div>
			</div>
		</div>
		


<!-- START Parse.ly Include: Standard -->

<script data-cfasync="false" id="parsely-cfg" data-parsely-site="housingwire.com" src="//cdn.parsely.com/keys/housingwire.com/p.js"></script>

<!-- END Parse.ly Include: Standard -->
<!--Enhanced Ecommerce Google Analytics Plugin for Woocommerce by Tatvic Plugin Version:2.3.2-->	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})()
	</script>
	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.housingwire.com\/articles\/florida-title-ceo-spurred-to-action-after-texas-winter-storms\/":307078};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/articles/florida-title-ceo-spurred-to-action-after-texas-winter-storms/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcGnrcUAAAAANojb5Y7q5Kpi7G-0qHELTXQ0vpi"
				data-theme="light"
				data-type="image"
				data-tabindex="0"
				data-lazy="true"
				data-url="https://www.google.com/recaptcha/api.js?hl=en_US"></div>
			
			<img style="float: right; display: none" class="loading" src="https://www.housingwire.com/wp-content/mu-plugins/jetpack-9.7/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>

		<div
			class="jp-carousel-wrap jp-carousel-transitions"
			itemscope
			itemtype="https://schema.org/ImageGallery"
			style="display: none;">
			<div class="jp-carousel-overlay"></div>
			<div class="jp-carousel"></div>
			<div class="jp-carousel-fadeaway"></div>
			<div class="jp-carousel-info">
				<div class="jp-carousel-photo-info">
					<h2 class="jp-carousel-caption" itemprop="caption description"></h2>
				</div>
				<div class="jp-carousel-info-columns">
					<div class="jp-carousel-left-column-wrapper">
						<div class="jp-carousel-titleanddesc"></div>
						<!-- Intentional duplicate -->
						<div class="jp-carousel-photo-info">
							<h2 class="jp-carousel-caption" itemprop="caption description"></h2>
						</div>
											</div>
					<div class="jp-carousel-image-meta">
						<div class="jp-carousel-buttons">
																				</div>
						<ul class="jp-carousel-image-exif" style="display: none;"></ul>
						<a class="jp-carousel-image-download" style="display: none;"></a>
						<div class="jp-carousel-image-map" style="display: none;"></div>
					</div>
				</div>
			</div>
			<div class="jp-carousel-next-button" style="display: none;">
				<span></span>
			</div>
			<div class="jp-carousel-previous-button" style="display: none;">
				<span></span>
			</div>
			<div class="jp-carousel-close-hint"><span>&times;</span></div>
		</div>

		<link rel='stylesheet' id='all-css-0' href='https://www.housingwire.com/wp-content/mu-plugins/jetpack-9.7/modules/carousel/jetpack-carousel.css?m=1619556058g' type='text/css' media='all' />
<script id='wc-add-to-cart-js-extra'>
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.housingwire.com\/checkout\/","is_cart":"","cart_redirect_after_add":"yes"};
</script>
<script id='woocommerce-js-extra'>
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
</script>
<script type='text/javascript' src='https://www.housingwire.com/_static/??-eJyljsEKwjAQRH/IZIkWPYlnP8APiMm2JG2yNbuh+PeG2oNHRZjDDDM8BpZZOcqCWWCe6hAyw0LkKCUsDsEyozDEpkfF8lT3idxYwxb1Gm9XnULWkXfwNa4v68yD9V4JKWeL/E6J3IY0BmxOv90fVz7qjXJJZ3Pcm5Mxh66LL9+lcRg='></script>
<script id='wc-cart-fragments-js-extra'>
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_eb369cd6be18f4eea08de13af0d52b44","fragment_name":"wc_fragments_eb369cd6be18f4eea08de13af0d52b44","request_timeout":"5000"};
</script>
<script src='https://www.housingwire.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=5.0.0' id='wc-cart-fragments-js'></script>
<script id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script id='vip-social-login-js-extra'>
var VSL = {"admin_ajax":"https:\/\/www.housingwire.com\/wp-admin\/admin-ajax.php","current_user_id":"0","nonce":"b92a94eb66","fb_app_id":"0","lnk_id":"78"};
</script>
<script id='how-main-js-extra'>
var HOW = {"home_url":"https:\/\/www.housingwire.com","has_category":"","has_tag":"1","is_single_post":"1","gated_content":"","gated_content_message":"<h4 style=\"text-align: center\">So you really like our content, huh? For continued access, complete your <a href=\"https:\/\/www.housingwire.com\/my-account\">free registration<\/a> today! Already registered? <a class=\"extras__login\" href=\"#\" data-open=\"loginModal\">log in<\/a><\/h4>\n","max_article_count":"5","is_logged_in":""};
</script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.housingwire.com\/wp-admin\/admin-ajax.php","nonce":"2851e96110","display_exif":"1","display_comments":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/www.housingwire.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.housingwire.com%2Farticles%2Fflorida-title-ceo-spurred-to-action-after-texas-winter-storms%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript' src='https://www.housingwire.com/_static/??-eJytkc1OwzAQhF8IZxWoqDggbr3QG70jx17SDWuv5Z+W8PQ4iFQR4tBIHD3rb2a8hnNQRnxGnyFw6cknODyrFzGkWe2lCqBTwpxgSBBKx2SaId3AgstHdJjgKCWR788UESylPAHJRGE+yI4+0K7gnCa/JqYKjDNA3nCx+N3YiHMVVhEDj41b54rxRAZ3Et0VVAVY+h6tkpJ/33dFzdsdMAdt3tVDs4UTeisRdMnidM5kLlPWn6Mip/uakqKZ3KlaxYQmk3jppnIYVRAe34j5r6f9R+hCWkYsV1yP6Lr6vddXeK08dIXYgtGxLhH5Mp+FH7sn99je37bbtr3bbIYvgxIArA=='></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://www.housingwire.com/wp-content/mu-plugins/jetpack-9.7/_inc/build/sharedaddy/sharing.min.js?ver=9.7' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
</script>
<!-- WooCommerce JavaScript -->
<script type="text/javascript">
jQuery(function($) { 
tvc_lc="USD";

tvc_smd={"tvc_wcv":"5.0.0","tvc_wpv":"5.7.2","tvc_eev":"2.3.2","tvc_cnf":{"t_ee":"","t_df":false,"t_gUser":false,"t_UAen":null,"t_thr":"6","t_IPA":false,"t_OptOut":false,"t_PrivacyPolicy":true}};
 });
</script>
<script src='https://stats.wp.com/e-202121.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'165477913',post:'307078',tz:'-4',srv:'www.housingwire.com'} ]);
	_stq.push([ 'clickTrackerInit', '165477913', '307078' ]);
</script>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a6c79fba96","applicationID":"261034550","transactionName":"ZVEBbBFTWRJRBUZeDFwbNkoKHV4PVANKGRNaRA==","queueTime":0,"applicationTime":457,"atts":"SRYWGllJSk0SBxANGE9J","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
